Join INGunOwners For Free
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 25 of 25
  1. #21
    Living in the E-File Poorhouse Yamadog35's Avatar

    User Info Menu

    I've gotten a number of Form 1 stamps from e-file before they closed it last time and I didn't get a physical stamp. It was always a PDF file with scanned representation of the stamp emailed to me. That's all I ever got. Is the new e-file system now sending physical stamps?

  2. #22
    Expert Ggreen's Avatar

    User Info Menu

    Quote Originally Posted by Yamadog35 View Post
    I've gotten a number of Form 1 stamps from e-file before they closed it last time and I didn't get a physical stamp. It was always a PDF file with scanned representation of the stamp emailed to me. That's all I ever got. Is the new e-file system now sending physical stamps?
    That was my impression, maybe we don't get the physical one.

    On a side note
    Both of my applications have been obliterated so I've been working with my investigator most of the day to get all my info back into their systems for the first. It's been a PITA and will likely be another once my 2nd gets to an investigator

  3. #23
    Perpetually Peeved Poultry AngryRooster's Avatar

    User Info Menu

    Filling out the form 1 right now and have a question.

    I just completed the part where you enter your make, model, SN, measurements, etc. It moved on to "step 3" attachment restrictions. It wants me to browse files and upload something and give a description, but it doesn't say what it wants. All it says is:

    Attachment restrictions:
    1. 10 attachments per line item
    2. Each attachemnt can be no larger than 3mb
    3. Total file size per submission can be no larger than 30mb
    4. Allowable file types:


    No idea what they are wanting here. I already uploaded my photo earlier. Don't think they want my ID here. Kind of stuck until I can find out. Thinking this may be for trust information. Not doing a trust, filing as an individual.
    Last edited by AngryRooster; 3 Days Ago at 23:25.
    Less & less amused every day...
    INGO #467

  4. #24
    Expert Ggreen's Avatar

    User Info Menu

    I uploaded nothing and both have moved into the investigation. I think that idea more for uploading plans etc than just filling for an sbr

  5. #25
    Perpetually Peeved Poultry AngryRooster's Avatar

    User Info Menu

    Quote Originally Posted by Ggreen View Post
    I uploaded nothing and both have moved into the investigation. I think that idea more for uploading plans etc than just filling for an sbr
    There was a pull down menu on the next page that had things like photos, schematics, etc. You're probably right.

    Found out that I'll have to wait a day or so to finish filing anyway. Not to happy with USAA right now. I added a PO box to my addresses so I could ship things there instead of having them sit out in the snow & slush this winter. It screwed up my account, told them a month ago to fix it, they said they did...Nope. Tried to order a radio this evening and it was rejected every time. Called them to find out WTF and they still had the PO box as my 'main' address. Told them to fix it right now. They deleted the PO box but told me it would take 2 days for the system to update everything. Tried to re-order the radio using the PO box, yep, already gone. Now I'm sitting here with a dead card until their system decided I exist in one of these places. That puts a damper on the Form 1 as well. Pretty pissed at them right now.
    Less & less amused every day...
    INGO #467

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •