Page 1 of 4 1 2 3 4 LastLast
Results 1 to 10 of 31
  1. #1
    Expert maxmayhem's Avatar
    Join Date
    Nov 2010
    Location
    Ocala, FL (for now)
    Posts
    2,056

    performance shield issue

    when firing the slide locks back and does not go forward. This is not caused by activating the slide stop accidentally as the back of the gun can be slapped and it goes back into battery. The gun is hanging up with rounds in the mag and its not caused by the slide stop. It is simply getting stuck.

    Major fail for smith and wesson as this is a performance center shield in 9mm. This was the first time shooting this shield as it was new. I had a problem with almost every magazine I ran through the gun. I have never had a problem of any kind with my other shield so I guess this POS is going back to the factory.

    Edit for clarity of what is happening:

    1) I load 5 rounds in the mag
    2) I fire one or two rounds and the slide simply "sticks" open.
    3) the slide stop is not causing this because you can firmly tap the back of the gun and it goes back into battery

    I experienced this failure at least once with all but maybe 2-3 mags out of 100 rounds.
    Last edited by maxmayhem; 01-07-2017 at 22:08.

  2. #2
    Expert NyleRN's Avatar
    Join Date
    Dec 2013
    Location
    Scottsburg
    Posts
    1,781
    Guess I'm not understanding what's occurring. When the slide reciprocates it's supposed to go back forward. Are you saying the slide is locking open with rounds still in the mag?

  3. #3
    Expert maxmayhem's Avatar
    Join Date
    Nov 2010
    Location
    Ocala, FL (for now)
    Posts
    2,056
    yes that is correct. I am not sure how to describe it because I have never seen a gun do this.

    So it goes like this.

    1) I load 5 rounds in the mag
    2) I fire one or two rounds and the slide simply "sticks" open.
    3) the slide stop is not causing this because I can firmly tap the back of the gun and it goes back into battery

    I experienced this failure at least once with all but maybe 2-3 mags out of 100 rounds.


    Quote Originally Posted by NyleRN ***Phone Number Hidden*** (See Rules for more info)bc062c3&p=6911044#post6911044" rel="nofollow">View Post
    Guess I'm not understanding what's occurring. When the slide reciprocates it's supposed to go back forward. Are you saying the slide is locking open with rounds still in the mag?

  4. #4
    Sharpshooter Roland of Gilead's Avatar
    Join Date
    Jan 2013
    Location
    Mars Hill
    Posts
    989
    Does it chamber the next round when you push it foward?
    Do the magazines function in an other Shield?
    The man in black fled across the desert, and the gunslinger followed.

  5. #5
    Expert maxmayhem's Avatar
    Join Date
    Nov 2010
    Location
    Ocala, FL (for now)
    Posts
    2,056
    all magazine functioned flawlessly in my other shield. It is not a magazine issue.
    It does chamber the round and fires. It just does not cycle as the slide stops at the rear

    Also the issue was duplicated with no magazine so something is out of spec with the firearm.

    Quote Originally Posted by Roland of Gilead ***Phone Number Hidden*** (See Rules for more info)bc062c3&p=6911119#post6911119" rel="nofollow">View Post
    Does it chamber the next round when you push it foward?
    Do the magazines function in an other Shield?
    Last edited by maxmayhem; 01-07-2017 at 15:06.

  6. #6
    Sharpshooter Roland of Gilead's Avatar
    Join Date
    Jan 2013
    Location
    Mars Hill
    Posts
    989
    Quote Originally Posted by maxmayhem ***Phone Number Hidden*** (See Rules for more info)bc062c3&p=6911136#post6911136" rel="nofollow">View Post
    all magazine functioned flawlessly in my other shield. It is not a magazine issue.
    It does chamber the round and fires. It just does not cycle as the slide stops at the rear

    Also the issue was duplicated with no magazine so something is out of spec with the firearm.
    Yeah sounds like it. Sucks to pay a premium for what should be a better than stock Shield and it not even run.
    The man in black fled across the desert, and the gunslinger followed.

  7. #7
    Grandmaster halfmileharry's Avatar
    Join Date
    Dec 2010
    Location
    South of Indy
    Posts
    7,503
    Strip out the slide and work the empty slide on the frame. I'm guessing the back of the frame or rear of the slide is sticking.
    IF you look closely at both the slide and frame you'll see where it's hanging up. It might be as simple as polishing out the guides in the frame or slide.
    The more you sweat in training the less you bleed in battle.

  8. #8
    Expert maxmayhem's Avatar
    Join Date
    Nov 2010
    Location
    Ocala, FL (for now)
    Posts
    2,056
    i compared the working shield with the defective shield and i cannot see a difference. I feel like smith and wesson should fix this- not me but I would like to be able to identify the issue.
    Quote Originally Posted by halfmileharry ***Phone Number Hidden*** (See Rules for more info)bc062c3&p=6911165#post6911165" rel="nofollow">View Post
    Strip out the slide and work the empty slide on the frame. I'm guessing the back of the frame or rear of the slide is sticking.
    IF you look closely at both the slide and frame you'll see where it's hanging up. It might be as simple as polishing out the guides in the frame or slide.

  9. #9

  10. #10
    Marksman Joniki's Avatar
    Join Date
    Nov 2013
    Location
    NE Indiana
    Posts
    692
    500 rounds through it will fix this problem.

    I just don't feel safe in gun free zones...

Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •